Skip to main content

The Bind-Off Process

Comments

35 comments

  • Gerard Rubio

    If issues persist, the next thing would be to look at the bind-off to understand what exactly goes wrong with those dropped stitches. To do that, you'd have to remove the brushes (please follow these instructions) and film it.

    Finding a good camera angle is important to have a clear vision of the needle action. Try to do it from above, a bit from the side if the carriage is getting on the way. (I took the video in that article by putting my phone above the yarn rails, not recommended though as it could crush your phone...)

    0
  • Cadenzaclothes

    Gerard Rubio I have already tried this and cannot get the camera to focus due to the moving parts.

    However I managed to get a better result having spent all week trying everything I and Robert Ingemarsson could think of.

    Now I am back to issues with the compiler. I design something in the app and it says it is a valid pattern, but then when I try to compile it there is always a "phantom" stitch error - right at the beginning of the bind off saying that there is a long float, on a row where the only thing happening is a transfer of one stitch, and I have only used one colour for the whole design. 

    I have tried both Chrome and Firefox, and both the design and staging apps. The frustrating thing is that this happens right at the end of designing something, and once the error is present it is impossible to get rid of, so all of my work is scrap. I spent all day designing a cable knit and trying repeatedly to get it to compile, despite the app saying it was a valid design. I only managed to get it to compile once late this afternoon. I saw from this one sample that I needed to edit a couple of roll down values, and when I tried to compile it after this edit, again the same error occurred.

    0
  • OJ

    Cadenzaclothes I've had the long float error a few times, too, with the suggestion to try birdseye even though the stitch pattern is a single color. Is this the same error? Do you get the birdseye suggestion? Each time I found I'd inadvertently gotten feeder 1 (draw) yarn into the pattern in an odd place!

    Switching to Pattern view, it was easy to spot the rogue yarn 1 in the pattern and easy to fix in the Front view if the error was with the front yarn. If error wasn't there, I could spot it in the Rear view. The error with the rear yarn was a little more complicated to fix.

    My solution was to remember the location of the error and change back to Stitches view. Select and copy a composite stitch where both front and rear yarns are correct. Then paste the stitch over the composite stitches with the error. 

     

    0
  • Cadenzaclothes

    OJ

    Hi and thanks for your feedback. I have found this trick too, with looking in pattern view and finding that somehow I have a stitch with the wrong yarn feeder, but it isn’t the same problem with the bind off.

    The row cited is always the first row of the bind off that just has one transfer stitch, and the error message is just that there is a long float. No mention of adding a Birdseye to resolve it. No amount of changing the view reveals an actual error anywhere that I can see, even zooming out and looking at the entire row including needles that aren’t in my knit. 

    I have tried using both iterations of the app in Firefox and Chrome but it doesn’t seem to make a difference. This is a problem I first encountered some weeks ago and I raised it as a bug. I wish I was confident enough to go into the k code and copy and paste a bind off onto my design to get around it, but I’m worried about getting it wrong and ending up with a problem with the machine....

    0
  • Robert Ingemarsson

    Looking forward to all of these tips and tricks getting incorporated into the templating software so binding off becomes easy rather than almost impossible at te moment ;)

    1

Please sign in to leave a comment.